SCM

[#6640] to built a new R package fails: Win10, RStudio

Date:
2019-10-23 10:47
Priority:
3
State:
Closed
Submitted by:
Eckhard Liebscher (eliebs)
Assigned to:
Nobody (None)
Hardware:
PC
Operating System:
Windows XP
Severity:
None
URL:
Summary:
to built a new R package fails: Win10, RStudio

Detailed description
Operating system windows 10

Hallo,
I try to install a new own R package including Rcpp functions in RStudio.
First I installed Rtools.
Then I clicked "Clean and Rebuild".

Now the system output:
******
==> Rcpp::compileAttributes()

* Updated R/RcppExports.R

==> Rcmd.exe INSTALL --preclean --no-multiarch --with-keep.source depcoeff

* installing to library 'o:........'
* installing *source* package 'depcoeff' ...
** using staged installation
** libs
Warnung in system(paste(cmd, "shlib-clean")) 'make' not found
Warnung in system(cmd) 'make' not found
ERROR: compilation failed for package 'depcoeff'
* removing 'o:/eckhard/stat/R/lib/depcoeff'

Exited with status 1.

WARNING: Rtools is required to build R packages but is not currently installed. Please download and install the appropriate version of Rtools before proceeding:

https://cran.rstudio.com/bin/windows/Rtools/
********
What is going wrong here? A similar output is generated clicking "Check".
Yours sincerely,
Eckhard

Comments:

Message  ↓
Date: 2019-10-25 12:51
Sender: Gennadiy Starostin

Sorry, this particular tracker is about the functionality of r-forge website. Please refer to other means, e.g. a general help forum, instead.
Best.

Attached Files:

Changes

Field Old Value Date By
status_idOpen2019-10-25 12:51gstar
close_dateNone2019-10-25 12:51gstar
Thanks to:
Vienna University of Economics and Business Powered By FusionForge