SCM

[#6637] Consulta sobre paquetes R-INLA y BAPC

Date:
2019-10-01 21:34
Priority:
3
State:
Closed
Submitted by:
Nora Díaz (nora)
Assigned to:
Nobody (None)
Hardware:
None
Operating System:
None
Severity:
None
URL:
Summary:
Consulta sobre paquetes R-INLA y BAPC

Detailed description
Estimados:
Mi nombre es Nora y necesito trabajar con modelos de edad périodo cohorte bayesiano. Soy nueva en R y me ha costado mucho instalar R-INLA y el paquete BAPC. Tengo 2 grandes consultas:

1) Cargué el paquete INLA, sin problemas (creo) usando los siguientes comando pero me da un mensaje de alerta. A continuación va lo que hice. Cómo puedo solucionar estos mensajes de alerta?Warning in install.packages :
dependencies ‘graph’, ‘Rgraphviz’ are not available


> remove(list=ls())
> getwd()
[1] "D:/Documents"
> install.packages("INLA", repos=c(getOption("repos"), INLA="https://inla.r-inla-download.org/R/testing";), dep=TRUE)
Warning in install.packages :
dependencies ‘graph’, ‘Rgraphviz’ are not available
trying URL 'https://inla.r-inla-download.org/R/testing/bin/windows/contrib/3.6/INLA_19.10.01.zip'
Content type 'application/zip' length 265680697 bytes (253.4 MB)
downloaded 253.4 MB

The downloaded binary packages are in
C:\Users\ndiazs\AppData\Local\Temp\Rtmp6r5peE\downloaded_packages

> library(INLA)
Loading required package: Matrix
Loading required package: sp
Loading required package: parallel
This is INLA_19.10.01 built 2019-10-01 18:12:05 UTC.
See http://www.r-inla.org/contact-us for how to get help.
> inla(formula=y~1,data=list(y=1:9))
Call:
"inla(formula = y ~ 1, data = list(y = 1:9))"
Time used:
Pre = 0.951, Running = 0.205, Post = 0.0262, Total = 1.18

2)
Intento cargar el paquete de BAPC y me arroja el siguiente mensaje de error


> install.packages("BAPC", repos="http://R-Forge.R-project.org";)

Warning in install.packages :
dependencies ‘caTools’, ‘fanplot’ are not available
installing the source package ‘BAPC’

trying URL 'http://R-Forge.R-project.org/src/contrib/BAPC_0.0.34.tar.gz'
Content type 'application/x-gzip' length 24299 bytes (23 KB)
downloaded 23 KB

ERROR: dependencies 'caTools', 'fanplot' are not available for package 'BAPC'
* removing 'D:/Documents/R/R-3.6.1/library/BAPC'
Warning in install.packages :
installation of package ‘BAPC’ had non-zero exit status

The downloaded source packages are in
‘C:\Users\ndiazs\AppData\Local\Temp\Rtmp6r5peE\downloaded_packages’

> library(BAPC)
Error in library(BAPC) : there is no package called ‘BAPC’


Luego intenté lo siguiente y me sigue arrojando error en la instalación.

> install.packages("BAPC", repos="http://R-Forge.R-project.org/src/contrib/BAPC_0.0.34.tar.gz";)

Warning in install.packages :
unable to access index for repository http://R-Forge.R-project.org/src/contrib/BAPC_0.0.34.tar.gz/src/contrib:
cannot open URL 'http://R-Forge.R-project.org/src/contrib/BAPC_0.0.34.tar.gz/src/contrib/PACKAGES'
Warning in install.packages :
package ‘BAPC’ is not available (for R version 3.6.1)
Warning in install.packages :
unable to access index for repository http://R-Forge.R-project.org/src/contrib/BAPC_0.0.34.tar.gz/bin/windows/contrib/3.6:
cannot open URL 'http://R-Forge.R-project.org/src/contrib/BAPC_0.0.34.tar.gz/bin/windows/contrib/3.6/PACKAGES


Agradeceré su ayuda.Soy nueva en el uso de R y no logro resolver esto.


Adjunto el script


Muchas gracias









L

Comments:

Message  ↓
Date: 2019-10-07 08:30
Sender: Gennadiy Starostin

Dear Nora Díaz,

I`m not sure what the non-English part of your inquiry says, but according to the output you provided I would suggest:

1) dependencies ‘graph’, ‘Rgraphviz’ are not available
You might want to install the dependencies from an official cran mirror (or from a repository were they are provided), e.g.

install.packages("graph",repos="https://cloud.r-project.org";)
install.packages("Rgraphviz",repos="https://cloud.r-project.org";)

2) ERROR: dependencies 'caTools', 'fanplot' are not available for package 'BAPC'

You might need to install the required packages from an official cran mirror first (or from a repository were they are provided), e.g.
install.packages("caTools",repos="https://cloud.r-project.org";)
install.packages("fanplot",repos="https://cloud.r-project.org";)

and then try installing the BAPC package again, i.e.
install.packages("BAPC", repos="http://R-Forge.R-project.org";)


As this tracker deals with R-Forge functionality only, for further help, please use the help forum instead:
https://r-forge.r-project.org/forum/forum.php?forum_id=78&group_id=34

Best regards,
Gennadiy.

Attached Files:

Attachments:
Size Name Date By Download
305 bytesscript de BAPC.R2019-10-01 21:34norascript de BAPC.R

Changes

Field Old Value Date By
status_idOpen2019-10-07 08:30gstar
close_dateNone2019-10-07 08:30gstar
File Added5184: script de BAPC.R2019-10-01 21:34nora
Thanks to:
Vienna University of Economics and Business Powered By FusionForge